Pronto Portal Browser Requirements

Please Note: This article relates to both the TM2 and TM3 versions of the desktop software.

For Pronto Portal to function as intended there are some browser requirements you should be aware of.  It requires;

  • Internet Explorer 10 and above
  • Recent Chrome
  • Recent Firefox
  • Recent Safari
  • Chrome (recent) browser for Android-based devices
  • Chrome (recent) / Safari for iOS devices.

You can check your browser via various means, usually, within the Help menu, there will be an "About" section.  Below is an example for Chrome;

Fig 1  - About Google Chrome

Fig 2 - Chrome Version

You could also use a site like http://www.whatsmybrowser.org/ to have the version checked automatically for you.  This method although convenient is not 100% accurate.